Yii Framework Forum: i don't install modules userGroups - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

i don't install modules userGroups Rate Topic: -----

#1 User is offline   phenomfx 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 9
  • Joined: 19-May 11

Posted 28 August 2011 - 10:47 AM

My Config
usergroups 1.8
Yii 1.1.8
XAMPP 1.7.4

<?php

// uncomment the following to define a path alias
// Yii::setPathOfAlias('local','path/to/local-folder');

// This is the main Web application configuration. Any writable
// CWebApplication properties can be configured here.
return array(
	'basePath'=>dirname(__FILE__).DIRECTORY_SEPARATOR.'..',
	'name'=>'TrackStar',
	'homeUrl'=>'/trackstar/project',
	

	// preloading 'log' component
	'preload'=>array('log'),

	// autoloading model and component classes
	'import'=>array(
		'application.models.*',
		'application.components.*',
		
		'application.modules.userGroups.models.*',
		
	),
	
	'modules'=>array(
	    'gii'=>array(
	          'class'=>'system.gii.GiiModule',
	          'password'=>'123456',
	    ),
	    
	   'userGroups'=>array(
		   'accessCode'=>'123456',
		   'salt'=>'123456', 
		),
	 ),

	// application components
	'components'=>array(
		'user'=>array(
			// enable cookie-based authentication
			'allowAutoLogin'=>true,
			//Grops
			'class'=>'userGroups.components.WebUserGroups',
		),
		
		'urlManager'=>array(
		    'urlFormat'=>'path',
		   
		    'showScriptName'=>false,   
		 ),    
		
		
		'db'=>array(
			'connectionString' => 'mysql:host=127.0.0.1;dbname=user2',
			'emulatePrepare' => true,
			'username' => 'root',
			'password' => '123456',
			'charset' => 'utf8',
	     ),
	
	     'authManager'=>array(
		    'class'=>'CDbAuthManager',
		    'connectionID'=>'db',
		 ),

		'errorHandler'=>array(
			// use 'site/error' action to display errors
            'errorAction'=>'site/error',
        ),
		'log'=>array(
			'class'=>'CLogRouter',
			'routes'=>array(
				array(
					'class'=>'CFileLogRoute',
					'levels'=>'error, warning, trace',
				),
				// uncomment the following to show log messages on web pages
				
				array(
					'class'=>'CWebLogRoute',
				),
				
			),
		),
	),

	// application-level parameters that can be accessed
	// using Yii::app()->params['paramName']
	'params'=>array(
		// this is used in contact page
		'adminEmail'=>'webmaster@example.com',
	),
	
	
	
);

The userGroups Module is not installed on your system.
0

#2 User is offline   Rock Cat 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 17
  • Joined: 16-February 11

Posted 02 September 2011 - 01:10 AM

the part 'urlManager', the url regular is missing.
just default look like:
'rules'=>array(
'<controller:\w+>/<id:\d+>'=>'<controller>/view',
'<controller:\w+>/<action:\w+>/<id:\d+>'=>'<controller>/<action>',
'<controller:\w+>/<action:\w+>'=>'<controller>/<action>',
),
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users