DB Naming Conventions Incompatibility?

Hi all,

Regarding to the Guide, conventions for database table names are as follows:

And that’s great! So now I have, let’s say tbl_my_table.

However, it’s a bit confusing to have different convention for table names of framework itself. I don’t understand why is for example “YiiLog” instead of “yii_log”, or even better “tbl_yii_log”?

I’m aware that’s possible to set custom names for tables to override, but conventions are conventions.

I wouldn’t pay much attention to THIS convention. I don’t prefix my tables, but using lowercase and underscopes. You can specify any table name in CActiveRecord.tableName() method.

I know that I can, but why not have everything under the same convention?

If you let any convention to go in some way - on the end you can have a real mess. This is not a big deal, but just a thought.

I just say my opinion :) I don’t see any problems if every one will name tables like he wants. There are more important conventions, class names for example. They should be named in Yii way.