Yii Framework Forum: i cant use any extension - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

i cant use any extension Rate Topic: -----

#1 User is offline   mostafa_khattab 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 19-March 09

Posted 16 May 2009 - 06:30 AM

:-[
i m beginner in this framework and im trying to use the editor extension
or the fckeditor extension but nothing work with me
can any buddy Please show me a detailed steps of installing extension

i have for example this error in the fckeditor when i try to put the editor in the protected/views/post/_form.php
.....................................
Error 500

"model" have to be set!

The above error occurred when the Web server was processing your request.
0

#2 User is offline   qwerty 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 290
  • Joined: 20-November 08

Posted 16 May 2009 - 07:02 AM

Hi,
could you enter the code you are using?
0

#3 User is offline   mostafa_khattab 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 19-March 09

Posted 16 May 2009 - 08:24 AM

ok  im using yii 1.0.4
and in trying to add the fckeditor to the blog example which is came with the demo
1- extracted the extension in /protected/extensions/  As fckeditor [folder]
2- as i want to use it in the posting i added this code to /protected/views/post/_form.php

<?php  $this->widget('application.extensions.fckeditor.FCKEditorWidget',array(

"model"=>$page,

"attribute"=>'content',

"height"=>'400px',

"width"=>'100%',

"fckeditor"=>Yii::app()->basePath."/../fckeditor/fckeditor.php",

"fckBasePath"=>Yii::app()->baseUrl."/fckeditor/",

"config" => array("EditorAreaCSS"=>Yii::app()->baseUrl.'/css/index.css',),

) );  ?>


thats all
if its important im using xampp on linux os ... and thank you for help
0

#4 User is offline   qwerty 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 290
  • Joined: 20-November 08

Posted 16 May 2009 - 12:57 PM

Hi,
it`s look fine. I try this cody by me and work. Make sure that you do not have the error by entering the URL to the editor in browser, ie:

http://127.0.0.1/www...r/fckeditor.php

and first of all check the web server logs. Maybe you have wrong permissions to the directory?
0

#5 User is offline   mostafa_khattab 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 3
  • Joined: 19-March 09

Posted 16 May 2009 - 04:52 PM

error 404 the page not found
and i don't have ie im using linux ... also i give all the folders 777 permission

any suggestions
0

#6 User is offline   Ascomae 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 49
  • Joined: 01-January 09
  • Location:Germany

Posted 18 May 2009 - 01:55 PM

Quote

"model" have to be set!


You have to set this configuration parameter.

In http://www.yiiframew...start.first-app you can read how to create a Datamodel. That model must exist. It must be a valid entry from the Databease (should be valid if you only edit the  [tt]/protected/model/<YOUR_MODEL>/update.php[/tt])


Christian

0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users