Yii Framework Forum: Yiiclipse - Eclipse PDT extension for Yii Framework - Yii Framework Forum

Jump to content

  • (5 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • 5
  • You cannot start a new topic
  • You cannot reply to this topic

Yiiclipse - Eclipse PDT extension for Yii Framework Rate Topic: ***** 5 Votes

#41 User is offline   KEo 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 24
  • Joined: 16-October 09
  • Location:Cracow, Poland

Posted 16 September 2011 - 02:21 PM

View Postlees, on 16 September 2011 - 03:07 AM, said:

I solved this problem.

But another problem happened to me~~~~

And I installed it success.

Attachment 1.jpg

Why I couldn't find the Yii project?

Attachment 2.jpg

BTW: I use zend studio.


There is no reason "Toggle Yii Support" is not visible. For ZendStudio 8.0.1 works fine.

Try to add yiiclipse nature manually.

Go to "PHP Explorer">View Menu(white triangle)>Filters.. and unselect ".* resources". OK

Double click on .project file and put
		<buildCommand>
			<name>org.maziarz.yiiclipse.builder</name>
			<arguments>
			</arguments>
		</buildCommand>
as buildSpec child, and
<nature>org.maziarz.yiiclipse.nature</nature>
as natures child

Now yii support should be on.
0

#42 User is offline   raviskiran 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 22-September 11

Posted 22 September 2011 - 05:41 AM

I have installed Yiiclipse for my eclipse 3.7 but only some part of the code is linking ..

for example I cant link to any part of the below code.

<?php $this->widget('zii.widgets.CListView', array(
'dataProvider'=>$dataProvider,
'itemView'=>'_view',
)); ?>
0

#43 User is offline   murphaph 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 29
  • Joined: 06-May 11

Posted 25 September 2011 - 09:58 AM

View Postitel, on 15 September 2011 - 04:06 PM, said:

Hi to all!
Can anybody help me with excluding yiilite.php from PHP Include Path in Eclipse?
I tried "Right click on project -> Properties -> PHP Include Path -> Libraries -> Add External Source Folder -> Access Rules -> Edit -> Resolution: Forbidden; Rule Pattern 'yiilite.php' -> OK", but it doesn't work. Is it a bug or I do something wrong?
Does exist any ways to exclude this file except removing it? For example, NetBeans or PhpStorm can ignore some files or folders, does Eclipse have such function? It's not a problem to remove yiilite.php, but there are some dynamic generated files (such as framework/cli/views/*, ...) wich I can't delete...

If we resolve this problem, it helps me to use Eclipse and Yii with more pleasure :)
P.S. using Yiiclipse I have the same problem. It will be exelent if this plugin exclude "bad" file automatically ;)

I have the same problem and it's quite annoying.

As a workaround I created a brand new project for the framework source and then clicked on yiilite.php in this new project and excluded yiilite from the build path. I then included this project in my other Yii projects and I can open declaration for classes and it will always open the framework base class, not the yiilite version. It's a bit of a hack but it seems to work.
0

#44 User is offline   dckurushin 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 392
  • Joined: 16-March 11
  • Location:Israel

Posted 25 September 2011 - 12:38 PM

In Zend Studio you have the option to add zend component if it is zend project, for exampel add Zend helper view, etc.

Would be cool if this plugin will have tha layout for controller, form model, ar model etc.
1

#45 User is offline   Roman Solomatin 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 181
  • Joined: 21-October 10
  • Location:Tallinn, Estonia

Posted 28 September 2011 - 01:38 PM

I like it, thanks!
0

#46 User is offline   jEMk 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 29-September 11

Posted 29 September 2011 - 05:15 AM

Hi KEo,

I have just installed the the Yiiclipse extension for Eclipse PDT. However I was unable to create a new Yiiclipse project as the option is not available. Neither was I able to Toggle Yii Support. Would appreciate it if you could provide some assistance. Thanks (=
0

#47 User is offline   Sisko 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 54
  • Joined: 27-September 10

Posted 29 September 2011 - 05:40 AM

View Postmurphaph, on 25 September 2011 - 09:58 AM, said:

I have the same problem and it's quite annoying.

As a workaround I created a brand new project for the framework source and then clicked on yiilite.php in this new project and excluded yiilite from the build path. I then included this project in my other Yii projects and I can open declaration for classes and it will always open the framework base class, not the yiilite version. It's a bit of a hack but it seems to work.


Is there a reason not to delete that file for the development environment?
0

#48 User is offline   KEo 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 24
  • Joined: 16-October 09
  • Location:Cracow, Poland

Posted 03 October 2011 - 04:01 PM

Hi all,

I have released version 1.1 with new cool features:
  • Alias code completion
  • Enhanced type inference (Yii::app()-> now returns CWebApplication, $this object in views returns CController object)
  • Exluding yiilite.php (actually just removing yiilite.php when unpacking yii archive)
  • Using custom remote yii framework location(append -Dryfl=[PATH|URL] to eclipse.ini file)


NOTE: From now most recent stable version will be available under the following updatesite location: http://yiiclipse.maz...atesite/STABLE/

Hope you found new features useful and as usually feedback is welcome.
0

#49 User is offline   Asgaroth 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 371
  • Joined: 17-July 09
  • Location:Bogota, Colombia

Posted 03 October 2011 - 04:06 PM

downloading now!!!
- Extension: Dynamic DataProvider Behavior
- Extension: XUpload - jQuery File Upload Extension
- Extension: PhpQuickProfiler - A Web Log Router that will help you profile your application
- Extension: XDateView - A Date grouped Grid View
- Extension: Foundation - An easy to use, powerful, and flexible framework for building prototypes and production code on any kind of device.



- Wiki: How to generate Yii like Documentation
- Wiki: How to re enable logging during unit testing
0

#50 User is offline   popo 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 31
  • Joined: 20-September 11
  • Location:xiamen

Posted 07 October 2011 - 11:03 AM

View PostKEo, on 16 September 2011 - 02:21 PM, said:

There is no reason "Toggle Yii Support" is not visible. For ZendStudio 8.0.1 works fine.

Try to add yiiclipse nature manually.

Go to "PHP Explorer">View Menu(white triangle)>Filters.. and unselect ".* resources". OK

Double click on .project file and put
		<buildCommand>
			<name>org.maziarz.yiiclipse.builder</name>
			<arguments>
			</arguments>
		</buildCommand>
as buildSpec child, and
<nature>org.maziarz.yiiclipse.nature</nature>
as natures child

Now yii support should be on.

Hi KEo
I also got the same problem. I install this twice, once in my office and this time. when I install in office, everything works fine, but now, I install successfuly, but can't see the toggle of Yii support.
My OS and eclips is all same with the office one.

I tried to fix it out by the step you mention, but I can't find the file in eclipse, how can I do it? My eclipse is :

Eclipse for PHP Developers

Version: Helios Service Release 2
Build id: 20110301-1815
0

#51 User is offline   KEo 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 24
  • Joined: 16-October 09
  • Location:Cracow, Poland

Posted 07 October 2011 - 03:09 PM

popo,

Run you PDT installation, go to top menu and choose Help > About Eclipse > Installation Details. You should see "Installed software" tab. There should be two position PDT and Yiiclipse. Can you see both??

Alternatively, you can try run your PDT from command line as follows:

./eclipse -debug -consoleLog


You should see the following entry at the end of internal eclipse debug log.

YDEBUG: Yiiclipse is up and running.


If you will be able to see it means yiiclipse is successfully installed. But the same this means not good if still dont see Configure > Toogle Yii Support popup menu.
0

#52 User is offline   yitzc 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 11-August 11

Posted 10 October 2011 - 12:33 PM

First of all, great job on this extension. The code navigation and completion features are really useful.

Unfortunately, the code completion for widgets doesn't seem to be working for me.
After typing
$this->widget('
it pops up a windows showing me the various options (application, ext, zii, etc.). However, after moving to the next part, it doesn't find anything ("No default proposals") - not for 'application', not for 'ext', and more importantly - not for zii.

In the meantime, I'll enjoy all the great features that do work.
0

#53 User is offline   Jaggi 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 90
  • Joined: 05-September 11

Posted 13 October 2011 - 04:40 PM

I have this running at home on Zend Studio on windows 7 but doesn't work at work unfortunately on my mac. Has anyone else tried this on a mac?
See my development site @ www.CodeTheInter.net (BETA)

Posted Image Posted Image

Quote

If you make it idiot proof, they'll build a better idiot
0

#54 User is offline   jimdamato 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 22-October 11

Posted 22 October 2011 - 04:26 PM

KEo,

First, thank you for your work on this.

Second, I do not see the links for navigation and I really want to. :) I am a recent convert to Mac and wonder if I'm just doing something wrong with the Mac version of Eclipse on this new OS.

However, I am also somewhat new to Eclipse and Yii after starting to write code again for the first time in 10 years, so maybe I have some of the installation wrong, but it doesn't seem like it because I can Toggle Yii Support just fine and see the icon change.

Thank you.
0

#55 User is offline   KEo 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 24
  • Joined: 16-October 09
  • Location:Cracow, Poland

Posted 22 October 2011 - 08:38 PM

jimdamato,

Unfortunately I have no possibility to check on Mac. Have you tried runing eclipse with -debug -consoleLog options? You should see error message when no possible to resolve the path.
0

#56 User is offline   yJeroen 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 94
  • Joined: 06-September 11
  • Location:The Netherlands

Posted 11 November 2011 - 04:31 AM

View PostKEo, on 16 September 2011 - 02:21 PM, said:

There is no reason "Toggle Yii Support" is not visible. For ZendStudio 8.0.1 works fine.

Try to add yiiclipse nature manually.

Go to "PHP Explorer">View Menu(white triangle)>Filters.. and unselect ".* resources". OK

Double click on .project file and put
		<buildCommand>
			<name>org.maziarz.yiiclipse.builder</name>
			<arguments>
			</arguments>
		</buildCommand>
as buildSpec child, and
<nature>org.maziarz.yiiclipse.nature</nature>
as natures child

Now yii support should be on.


This doesn't work for me.. I have Eclipse 3.7 and I dont get the Configure>Toggle Yii Support option.

Here's part of my .project file:
	<buildSpec>
		<buildCommand>
			<name>org.eclipse.wst.validation.validationbuilder</name>
			<arguments>
			</arguments>
		</buildCommand>
		<buildCommand>
			<name>org.eclipse.dltk.core.scriptbuilder</name>
			<arguments>
			</arguments>
		</buildCommand>
		 <buildCommand>
                        <name>org.maziarz.yiiclipse.builder</name>
                        <arguments>
                        </arguments>
		 </buildCommand>
	</buildSpec>
	<natures>
		<nature>org.eclipse.php.core.PHPNature</nature>
		<nature>org.maziarz.yiiclipse.nature</nature>
	</natures>

0

#57 User is offline   Aladdin 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 54
  • Joined: 20-July 11

Posted 27 November 2011 - 03:00 AM

I still have this error:
Cannot complete the install because one or more required items could not be found.
Software being installed: Yiiclipse Core 1.1.0.201111132221 (org.maziarz.yiiclipse.feature.feature.group 1.1.0.201111132221)
Missing requirement: Yiiclipse Core 1.1.0.201111132221 (org.maziarz.yiiclipse.feature.feature.group 1.1.0.201111132221) requires 'org.eclipse.php.feature.group 0.0.0' but it could not be found

I tried almost everything in this thread.
is there a way to manually installation?
0

#58 User is offline   two_socks 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 14
  • Joined: 01-December 11
  • Location:Ireland

Posted 01 December 2011 - 07:50 PM

Hi KEo,
I am a newbie with Yii and I have a small problem with Yiiclipse.

My Yii's directory structure is a little bit different from standard structure, I have put the protected directory outside the webroot and I changed the index.php.
Now, when I create a new Yii project in Eclipse, it (Eclipse or Yiiclispe I do not know) recreates the protected directory inside the webroot and I cannot to change the path.

How I can link the protected directory outside the webroot?
Is it a limitation of Yiiclipse or my mistake?

Thanks,
KK
0

#59 User is offline   jacmoe 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 2,601
  • Joined: 10-October 10
  • Location:Denmark

Posted 01 December 2011 - 08:04 PM

YiiClipse is probably using a script to do its magic.
I am just guessing, haven't actually used it myself.
What you describe happens suggest that it is so. ;)
"Less noise - more signal"
0

#60 User is offline   tommyhp2 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 10
  • Joined: 27-November 11

Posted 02 December 2011 - 08:07 AM

Thanks KEo! Awesome tool and working good for Indigo SR1 with PDT 3.0.0
0

Share this topic:


  • (5 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • 5
  • You cannot start a new topic
  • You cannot reply to this topic

2 User(s) are reading this topic
1 members, 1 guests, 0 anonymous users

  1. Velvetyej