Yii Framework Forum: [SOLVED] Authmanager error - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

[SOLVED] Authmanager error help

#1 User is offline   sasori 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 297
  • Joined: 05-November 10

Posted 16 November 2010 - 01:02 AM

Hi,

am still at the trackstar , chapter 8, if such error like this occurs, where should I look for the error?
it doesn't tell which file, just the module :S, as far as I can see, I only used the authManager thing at the RbacCommand.php file

Posted Image
0

#2 User is offline   jefftulsa 

  • Advanced Member
  • Yii
  • Group: Yii Dev Team
  • Posts: 168
  • Joined: 06-October 08
  • Location:Austin, TX

Posted 16 November 2010 - 01:17 AM

Can you confirm that your main config file: /protected/config/main.php does, indeed, have the auth manager configured as an application component (as discussed on pg 179 of the book)? Something along the lines of:

// application components
	'components'=>array(
		
    	...
		
		'db'=>array(
			'connectionString' => 'mysql:host=127.0.0.1;dbname=trackstar_dev',
			'emulatePrepare' => true,
			'username' => 'root',
			'password' => '',
			'charset' => 'utf8',
	 	),
	
	 	'authManager'=>array(
			'class'=>'CDbAuthManager',
			'connectionID'=>'db',
		 ),
  
    	...


0

#3 User is offline   sasori 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 297
  • Joined: 05-November 10

Posted 16 November 2010 - 01:20 AM

ok problem solved, by the default the gii code

thanks alot
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users