Yii Framework Forum: 500 Internal Server Error - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

500 Internal Server Error moved from one to another ISP Rate Topic: -----

#1 User is offline   pc131 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 133
  • Joined: 28-July 10
  • Location:Warsaw, Poland

Posted 03 November 2010 - 05:44 PM

Hi

I downloaded Yii app from one server and uploaded it to another server (both Unix'es). On first it runs OK.

On second server I chmod'ed myapp/protected/runtime to 777:

Posted Image

But still cannot open default app page:

Posted Image

Do I have to chmod another directories?

Thanks in advance.
0

#2 User is offline   tri 

  • Elite Member
  • Yii
  • Group: Moderators
  • Posts: 1,651
  • Joined: 20-November 08
  • Location:Stockholm, Sweden

Posted 03 November 2010 - 06:07 PM

Yes, myapp/assets also need write permission.
Don't forget to read The Definitive Guide to Yii (en) (sv) | The class reference has the details
0

#3 User is offline   pc131 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 133
  • Joined: 28-July 10
  • Location:Warsaw, Poland

Posted 03 November 2010 - 06:29 PM

View Posttri, on 03 November 2010 - 06:07 PM, said:

Yes, myapp/assets also need write permission.


It worked! Thanks.
0

#4 User is offline   illya 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 11-January 12

Posted 11 January 2012 - 07:00 AM

I went through the setup process on a local server all was fine.
I must say the install instructions brought me back to uni setting path variables...


So then I tried the face book plugin tried for some time could not get it to work.

So I thought I would start fresh on my server cpanel/centos.

Made a sub domain (yii)

uploaded all the files to the root dir www/public_html

ssh into the server

run the php command to install in yii (the same dir as the sub domain I made in cpanel)

chomded all the files

Internal Server Error 500

Now I have just chomded all the files to 777 inside the yii dir with file zilla recursively

and and as a last resort chomded all the files in framework to 777 also

Still have Internal Server Error 500

and yes rewrite is enabled

httpd -l | grep -i rewrite
mod_rewrite.c


and no error_log files


any ideas would be helpful thanks
0

#5 User is offline   View Finder 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 42
  • Joined: 11-December 11

Posted 11 February 2012 - 11:05 AM

I had a similar problem with GoDaddy share host. And it turned out the problem was with the .htaccess

In the WebRoot folder the .htaccess looks like this:


Options +FollowSymLinks
IndexIgnore */*
RewriteEngine on
# for GoDaddy
Rewritebase /

# if a directory or a file exists, use it directly
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

# otherwise forward it to index.php
RewriteRule . index.php



Note the 'for GoDaddy' line, that's what has to be added to make that error 500 go away though I did't need it on my dev server.
0

#6 User is offline   akitikkx 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 2
  • Joined: 10-June 12
  • Location:South Africa

Posted 29 December 2012 - 01:41 PM

Thank you for the .htaccess solution, worked brilliantly for me. I also have a GoDaddy setup
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users