Yii Framework Forum: Не видит таблицу в базе - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Не видит таблицу в базе Rate Topic: -----

#1 User is offline   Zolter 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 377
  • Joined: 26-March 09

Posted 26 March 2009 - 08:55 AM

Всем привет.
Вот недавно начал ковырять Yii, интересная вещь только в плане доки скудновато. Ну да ладно, вопрос вот в чем.

Ловлю я на экране исключение "The table "user" for active record class "Users" cannot be found in the database."

Таблица user естественно в базе есть. База называется test

Вот конфиг:

  ....
'import'=>array(
'application.models.*',
),
  ....
'db'=>array(
'connectionString'=>'mysql://root@localhost/test',
),
  ....


Вот модель:

<?php

class Users extends CActiveRecord
{

    public static function model($className=__CLASS__)
    {
        return parent::model($className);
    }
   
public function tableName()
{
return 'user';
}
}


В контроллере делаю
$users = new Users;


и получаю на экран исключение что такой таблицы не найденно. вот дамп таблички:


CREATE TABLE IF NOT EXISTS `user` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `login` varchar(250) NOT NULL,
  `passwd` varchar(250) NOT NULL,
  PRIMARY KEY (`id`)
) ENGINE=MyISAM  DEFAULT CHARSET=utf8 AUTO_INCREMENT=2 ;


Отсюда вопрос что может быть? Таблица в базе есть. Конфиг сделан как я понял правильно.
0

#2 User is offline   carat 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 60
  • Joined: 12-February 09

Posted 26 March 2009 - 09:05 AM

а у меня в конфиге во как:
[tt]        'db'=>array(
            'class'=>'system.db.CDbConnection',
            'connectionString'=>'mysql:host=localhost;dbname=mydatabase;',
            'username'=>'root',
            //'password'=>'',[/tt]

0

#3 User is offline   Burashevo 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 20-March 09

Posted 26 March 2009 - 09:07 AM

Ну у меня конфиг немного по-другому выглядит. Вот так:

'db'=>array(
  'class'=>'CDbConnection',
  'connectionString'=>'mysql:host=localhost;dbname=my_db',
  'username'=>'my_login',
  'password'=>'my_password',
),

Попробуй своё на что-то похожее поменять.


0

#4 User is offline   Burashevo 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 4
  • Joined: 20-March 09

Posted 26 March 2009 - 09:08 AM

Quote

а у меня в конфиге во как:

[tt]        'db'=>array(

            'class'=>'system.db.CDbConnection',

            'connectionString'=>'mysql:host=localhost;dbname=mydatabase;',

            'username'=>'root',

            //'password'=>'',[/tt]


быстрее пишешь.)
0

#5 User is offline   Zolter 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 377
  • Joined: 26-March 09

Posted 26 March 2009 - 10:00 AM

прикол когда ставлю то что вы предложыли - у меня сначало браузер подвисает на пару сек а затем апач вешается :( щяс наверно ксамп буду переставлять и потом скажу помогло или нет.
0

#6 User is offline   carat 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 60
  • Joined: 12-February 09

Posted 26 March 2009 - 10:15 AM

а воопче то я думаю у тебя ляпсус. ты к той базе конектишься?
0

#7 User is offline   Zolter 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 377
  • Joined: 26-March 09

Posted 26 March 2009 - 11:12 AM

Quote

а воопче то я думаю у тебя ляпсус. ты к той базе конектишься?


к той
0

#8 User is offline   Zolter 

  • Advanced Member
  • PipPipPip
  • Yii
  • Group: Members
  • Posts: 377
  • Joined: 26-March 09

Posted 26 March 2009 - 11:34 AM

Всем спасибо за предоставление нормального конфига. Мой действительно был не правельный (хотя странно т.к. нашол такую структуру записи в вики примере). А подвисал у меня апач из-за каких то траблов с xampp-ом. Сейчас поставил ZendServer, прописал конфиг что вы дали - и все работает на ура. :)
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users