Yii Framework Forum: isAttributeRequired() - Yii Framework Forum

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

isAttributeRequired() isAttributeRequired() Rate Topic: -----

#1 User is offline   dudunegrinhu 

  • Junior Member
  • Pip
  • Yii
  • Group: Members
  • Posts: 31
  • Joined: 05-August 10

Posted 05 August 2010 - 11:58 PM

Hello,

I inserted this code:
<?php echo CHtml::activeLabelEx($event,'remind'); ?>
    <?php echo CHtml::activeTextField($event,'remind',array("id"=>"remind")); ?>
    &nbsp;(calendar with time , position 400,200 and a range 2008-2010)
    <?php $this->widget('application.extensions.calendar.SCalendar',
        array(
        'inputField'=>'remind',
       'ifFormat'=>'%Y-%m-%d %H:%M',
        'showsTime'=>true,
        'position'=>"[400,200]",
        'range'=>"[2008,2010]"
    ));
    ?>


in the calendar extension: http://www.yiiframew...n/calendar/#doc
and I'm gettin this error:


Fatal error: Call to a member function isAttributeRequired() on a non-object in /Applications/XAMPP/xamppfiles/htdocs/yii/framework/web/helpers/CHtml.php on line 1154

so I'm not able to see my calendar.
Any idea?

BR,
Dudu
0

#2 User is offline   megant 

  • Newbie
  • Yii
  • Group: Members
  • Posts: 1
  • Joined: 03-September 10

Posted 03 September 2010 - 05:51 AM

View Postdudunegrinhu, on 05 August 2010 - 11:58 PM, said:

Hello,

I inserted this code:
<?php echo CHtml::activeLabelEx($event,'remind'); ?>
    <?php echo CHtml::activeTextField($event,'remind',array("id"=>"remind")); ?>
    &nbsp;(calendar with time , position 400,200 and a range 2008-2010)
    <?php $this->widget('application.extensions.calendar.SCalendar',
        array(
        'inputField'=>'remind',
       'ifFormat'=>'%Y-%m-%d %H:%M',
        'showsTime'=>true,
        'position'=>"[400,200]",
        'range'=>"[2008,2010]"
    ));
    ?>


in the calendar extension: http://www.yiiframew...n/calendar/#doc
and I'm gettin this error:


Fatal error: Call to a member function isAttributeRequired() on a non-object in /Applications/XAMPP/xamppfiles/htdocs/yii/framework/web/helpers/CHtml.php on line 1154

so I'm not able to see my calendar.
Any idea?

BR,
Dudu


Hi,

I've got the same error message running the blog demo, when I try to click on the title of a specific blog entry.
0

#3 User is offline   kael 

  • Standard Member
  • PipPip
  • Yii
  • Group: Members
  • Posts: 140
  • Joined: 13-September 10
  • Location:静岡、 静岡、 日本 と フィリピン

Posted 13 September 2010 - 10:33 PM

View Postmegant, on 03 September 2010 - 05:51 AM, said:

Hi,

I've got the same error message running the blog demo, when I try to click on the title of a specific blog entry.



got the same problem too but only when i try to access the login page. T_T
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users