Yii 2.0: yii2-widget-touchspin

Yii2 wrapper for the bootstrap-touchspin spinner component

Latest Stable Version License Total Downloads Monthly Downloads Daily Downloads

The TouchSpin widget is a Yii 2 wrapper for for the bootstrap-touchspin plugin by István Ujj-Mészáros, with certain additional enhancements. This input widget is a mobile and touch friendly input spinner component for Bootstrap 3. You can use the widget buttons to rapidly increase and decrease numeric and/or decimal values in your input field. The widget can be setup to include model validation rules for the related model attribute.

Note: This extension is a sub repo split of yii2-widgets. The split has been done since 08-Nov-2014 to allow developers to install this specific widget in isolation if needed. One can also use the extension the previous way with the whole suite of yii2-widgets.


The preferred way to install this extension is through composer. Check the composer.json for this extension's requirements and dependencies. Read this web tip /wiki on setting the minimum-stability settings for your application's composer.json.

To install, either run

$ php composer.phar require kartik-v/yii2-widget-touchspin "@dev"

or add

"kartik-v/yii2-widget-touchspin": "@dev"

to the require section of your composer.json file.

Latest Release

Note: The latest version of the module is v1.2.0 released on 04-Dec-2014. Refer the CHANGE LOG for details.


You can refer detailed documentation and demos on usage of the extension.


use kartik\touchspin\TouchSpin;
echo TouchSpin::widget([
    'name' => 'volume',
    'options' => ['placeholder' => 'Adjust...'],
    'pluginOptions' => ['step' => 1]


yii2-widget-touchspin is released under the BSD 3-Clause License. See the bundled LICENSE.md for details.



Be the first person to leave a comment

Please to leave your comment.

Create extension
No downloadable files yet