Yii 2.0: yii2-semantic-ui

Extension Library for the Semantic UI framework
3 followers

This is the Semantic UI extension for Yii 2. It encapsulates Semantic UI components and plugins in terms of Yii widgets and helper classes, easing the usage of Semantic UI components/plugins into Yii 2 applications.

Install

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist "2amigos/yii2-semantic-ui": "*"

or add

"2amigos/yii2-semantic-ui": "*"

to the require section of your composer.json file.

Usage

We are in the process of building a site for this extension but, in the meantime, for example, making use of the Dropdown module widget with a search-in menu feature is as follows:

echo Dropdown::widget([
    'encodeText' => false,
    'text' => '<i class="filter icon"></i><span class="text">Filter posts</span>',
    'icon' => false,
    'displaySearchInput' => true,
    'encodeItemLabels' => false,
    'items' => [
        '<div class="header"><i class="tags icon"></i>Tag Label</div>',
        ['label' => '<div class="ui red empty circular label"></div>Important'],
        ['label' => '<div class="ui blue empty circular label"></div>Announcement']
    ],
    'options' => [
        'class' => 'floating labeled search icon button'
    ],
]
);

Resources

2amigOS!
web development has never been so fun
www.2amigos.us

Be the first person to leave a comment

Please to leave your comment.

Create extension
Downloads
No downloadable files yet