Yii 1.1: elrte

Allows to add elRTE to a view
2 followers

This extension is add eLRTE

Resources

Documentation

Requirements

  • Yii 1.0 or above

Installation

  • Extract the release file under protected/extensions

Usage

Change Log

December 2, 2009

  • Initial release.

Total 2 comments

#11902 report it
kernel32ddl at 2013/02/12 05:26am
Problem in 1.1.13

From 1.1.13 JQuery UI is a part of framework, to prevent conflicts need register JQuery UI as core script in file elRTE.php

$ClientScript->registerCoreScript('jquery.ui');               
//$ClientScript->registerScriptFile("{$this->baseUrl}/js/jquery-ui-1.8.13.custom.min.js");
$ClientScript->registerScriptFile("{$this->baseUrl}/js/elrte.full.js");             
$ClientScript->registerCssFile("{$this->baseUrl}/css/smoothness/jquery-ui-1.8.13.custom.css");
#1094 report it
StranNik at 2009/12/10 03:20am
Спасибо!

Мне очень пригодилось.

Но 163 строку в файле виджета надо бы убрать


162:$clientScript->registerCoreScript('jquery');
163:$clientScript->registerScriptFile($baseUrl.'/js/jquery.js');
Так она подключает JQuery второй раз из другой папки и вызывает конфликты с ранее поключеными плагинами

Leave a comment

Please to leave your comment.

Create extension
Downloads