Yii 2.0: bootstrap-rtl

The Twitter Bootstrap Rtl extension for the Yii 2.0 framework
4 followers

Twitter Bootstrap RTL Extension for Yii 2

This is the Twitter Bootstrap RTL (Right to Left) extension for Yii 2. It create an AssetBundle for Rtl bootstrap.

Installation ΒΆ

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist airani/yii2-bootstrap-rtl

or add

"airani/yii2-bootstrap-rtl": "*"

to the require section of your composer.json file.

For using this asset bundle you need just add this line 'airani\bootstrap\BootstrapRtlAsset' in $depends of AppAsset or any asset bundels you work that.

Example:

namespace backend\assets;
 
use yii\web\AssetBundle;
 
class AppAsset extends AssetBundle
{
    public $basePath = '@webroot';
    public $baseUrl = '@web';
    public $css = [
        'css/site.css',
    ];
    public $depends = [
        'yii\web\YiiAsset',
        'yii\bootstrap\BootstrapAsset',
        'airani\bootstrap\BootstrapRtlAsset',
    ];
}

Total 2 comments

#19386 report it
yiiesss at 2015/06/13 02:52pm
another prompt

now i am getting:

Problem 1
    - Installation request for airani/yii2-bootstrap-rtl 1.1 -> satisfiable by airani/yii2-bootstrap-rtl[1.1].
    - airani/yii2-bootstrap-rtl 1.1 requires bower-asset/bootstrap-rtl * -> no matching package found.
 
Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.
#19385 report it
yiiesss at 2015/06/13 10:51am
problem during install

Hello

i got this error during install :

Your requirements could not be resolved to an installable set of packages.
 
  Problem 1
    - Installation request for airani/yii2-bootstrap-rtl dev-master -> satisfiable by airani/yii2-bootstrap-rtl[dev-master].
    - airani/yii2-bootstrap-rtl dev-master requires bower-asset/bootstrap-rtl * -> no matching package found.
 
Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.
 
Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
 
Installation failed, reverting ./composer.json to its original content.

even i have configured the composer.json

"minimum-stability": "dev",
    "prefer-stable" : true,

Leave a comment

Please to leave your comment.

Create extension